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1. Introduction
Ce document présente sommairement une méthode de conception de circuits électroniques à l'aide

du logiciel Altium Designer. 

Il fait suite au module de premier semestre qui a permis de prendre en main le logiciel et effectuer

des simulations Spice. Il se concentre sur le flot de conception d'une carte.

Ce document s'appuie notamment sur les documents édités par Altium « Altium Designer Training 

for Schematic Capture and PCB Editing » disponibles à l'adresse suivante : 

http://altium.com/training/en/manuals-and-downloads.cfm
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2. Flot de conception d'une carte

3. Création du projet PCB
Pour commencer, il faut créer un projet de type PCB par  File>New>Project>PCB Project, puis

l'enregistrer (garder l'extension par défaut .PrjPCB) par File>Save Project As … (ou clique bouton

droit sur le nom du projet puis Save Project As). 

Alexandre Boé 4/30

Figure 1: Flot de conception d'une carte
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3.1 Création du schéma électronique

La deuxième étape consiste à ajouter au projet un ou plusieurs schémas par File>New>Schematic

(ou  clique  bouton  droit  sur  le  nom  du  projet  puis

Add New to Project>Schematic). Vous pouvez dès lors

sauvegarder votre schéma. La feuille insérée est vierge et

va recevoir votre schéma électronique. Avant cette saisie,

il est possible de modifier les options de votre document

par  Design>Document Options...,  notamment  l'onglet

Units qui  permet  de choisir  les unités  Imperial (unités

anglaises  basées  sur  le  pouce  ou  inch,  égal  25,4 mm)

traditionnellement utilisées en électronique ou les unités

métriques plus classiques.

Comme vu au premier semestre, vous pouvez alors saisir

votre schéma en utilisant les bibliothèques de composants

existantes. Dans le cas où le composant à utiliser n'existe

pas dans les bibliothèques standards, consultez l'Annexe

1 qui explique comment créer ses propres composants.

Veuillez à bien choisir les composants que vous utilisez.

En effet, un composant comporte différentes entités : un

dessin schématique, un modèle pour la simulation Spice

(éventuellement  des  modèles  pour  d'autres  types  de

simulations  telles que l'intégrité  de signal,  …),  une ou

plusieurs empreintes (ou  footprint, dessin qui représente

les parties cuivrées sur lesquelles le composant va être soudée). En fonction de l'application visée

(fréquence de travail,  taille  du circuit,  …) et  de la  valeur du composant,  vous privilégierez un

boîtier particulier (composant de surface ou traversant, taille, ...). Par exemple, un condensateur de

quelques picofarads aura une empreinte avec un pas de 2,54 mm tandis qu'un gros condensateur

électrochimique de quelques millifarads pourra avoir un pas de plus de 30 mm. Il faut donc penser,

dès le début de votre conception, au type de composant utilisé.

Au final, vous obtenez quelque chose ressemblant à la Figure 3. 
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Figure 2: Projet PCB et fichier schématique
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Figure 3: Schématique

Afin  de  vérifier  la  cohérence  de  votre  schématique,  compilez  celle-ci  par

Project>Compile Document.  En  cas  d'erreurs,  apportez  les  corrections  nécessaires ;  les

avertissements  ne  sont  pas  forcément  corrigés  mais  attirent  votre  attention  sur  certains  points

incohérents (par exemple liaison entre deux broches de type output) … à quand même regarder avec

attention !

3.2 Simulation Spice

Dans  certains  cas,  il  est  possible  de  simuler  le  fonctionnement  de  la  schématique  (si  tous  les

composants utilisés possèdent un modèle, ce qui n'est pas le cas de la Figure 3). Pour tout ce qui est

simulation, reportez-vous au documents fournis au premier semestre.

Bien que fortement conseillée, la simulation n'est pas forcément possible. Même si une simulation

est faite, gardez bien à l'esprit que la réalité peut être différente, notamment à cause d'effets non pris

en compte dans les modèles ou des tolérances des composants utilisés (20% pour les condensateurs,

5 ou 10% pour les résistances).
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3.3 Création du PCB et synchronisation avec schéma

Une fois la schématique terminée, il est nécessaire de créer un

fichier  PCB  qui  contiendra  une  vue  de  la  carte  physique

(placement des composants, interconnexions en cuivre, trous,

…).  Pour  cela,  deux  méthodes :  soit  manuelle  (ajout  d'un

fichier  PCB  par  Project>Add New To Project>PCB,  puis

définition des différents paramètres) soit  à l'aide du  wizard

(en allant dans l'onglet File puis New from template puis PCB

Board Wizard, cf. Figure 4).

Vous pouvez dès lors vous laisser guider par le logiciel en

choisissant  les unités,  la taille de la  carte,  les détails  de la

carte (notamment les dimensions « internes » de la carte, c'est

à  dire  la  taille  maximale  utilisée  par  les  composants  et  le

routage). Ces différentes options pourront de toute façon être

modifiées par la suite.

Le nombre de couches de signaux est fixée, dans notre cas

soit à une soit à deux (nous ne disposons pas de l'équipement

pour faire des circuits multi-couches) ; le nombre de couche

d'alimentation est quant à lui fixé à zéro. En cas de routage de

carte très complexe, on peut utiliser une troisième couche qui

sera en fait réalisée physiquement avec des morceaux de fils

isolés  (strap).  Les  trous  utilisés  sont  des  Thruhole Via Only.  Choisissez  ensuite  le  type  de

composants majoritaires (traversants ou de surface) et indiquez si les composants peuvent être sur

les deux faces (non souhaitable si tous les composants sont traversants).  Avant de terminer (cf.

Figure 5), quelques règles de routage peuvent être définies, mais nous reviendrons sur ce point

après.
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Figure 4: Création d'un fichier PCB à
l'aide du wizard
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Figure 5: Fichier PCB créé automatiquement

Le PCB créé est vierge. Il convient donc de transférer la schématique (composants et liaisons entre

eux) ;  pour cela,  Design>Update PCB Document.  Le logiciel  vous résume toutes les actions à

entreprendre,  notamment  les  composants  à  ajouter  sur  le  PCB.  Sauf  utilisation  avancée,  vous

pouvez valider puis exécuter les changements proposés (cf. Figure 6). 

Figure 6: Transfert de la schématique vers le PCB

Votre PCB doit alors avoir l'allure de la Figure 7. On y retrouve à gauche le PCB toujours vierge et

Alexandre Boé 8/30



Conception circuits électroniques Mars 2015

en bas à droite, les composants avec leurs interconnexions. Celles-ci (on parle de  chevelu) sont

représentées par des segments en blanc ici reliant directement les broches des composants, sans se

soucier d'aucune contrainte physique.

Figure 7: Vue du PCB avec les composants

3.4 Placement des composants

Avant d'aborder ces deux étapes cruciales, revenons un peu plus en détail sur la notion de couches

(layers). Les définitions des différentes couches est accessible par Design>Layer Stack Manager,

Design>Board Layers & Colors … et  Design>Manage Layer Sets>Board Layer Sets …. Il faut

tout  d'abord  préciser  que  cette  notion  est  abstraite :  les  couches  peuvent  être  physiques  (donc

réellement  réalisées)  ou  de  dessin  (pas  forcément  réalisées).  Le  logiciel  permet  de  définir  32

couches physiques de routage (couches  sur lesquelles on dessine les lignes d'interconnexion en

cuivre) et 32 couches autres. Parmi celles-ci on retrouve des couches de fabrication (couches Paste

ou Solder) utilisée lors d'une fabrication industrielle et des couches de texte (couches Overlay) qui

permettent  de  représenter  les  composants  ou  certaines  informations  telles  que  la  valeur  du

composant. Dans le cas d'une fabrication industrielle, ces couches sont imprimées par sérigraphie

sur  la  carte  (les  inscriptions  généralement  en blanc sur  les  cartes  électroniques) ;  pour  nous ça

restera une aide visuelle, mais n'aura aucun impact sur la carte physique.

Les deux couches les plus importantes dans notre cas sont les couches Top (généralement en rouge)

et  Bottom (généralement  en  bleu).  Ces  deux  couches  physiques  vont  servir  à  dessiner  les

interconnexions en cuivre. Par convention, les composants traversants sont placé sur le dessus de la

carte (donc en top) et les lignes de connexions sont routées en Bottom. Dans le cas de cartes mixtes

avec  des  composants  traversants  et  des  composants  de  surface,  vous  pourrez  aussi  placer  des

composants en face  Bottom.  Dans ce cas,  pensez à  l'indiquer  au logiciel  (double-cliquez sur le

composant et changez son layer en haut à gauche) pour qu'il puisse lui appliquer un effet miroir. À
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noter  qu'il  est  proscrit  de  mettre  en  composants  traversant  sur  une  face  et  de  router  des

interconnexions  vers  ce  composant  sur  la  même  face,  il  ne  sera  pas  possible  de  le  souder

correctement (il faudrait avoir accès à des trous métal, non disponibles à Polytech'Lille).

La  première  étape  consiste  à  placer  les  composants  sur  la  carte.  Pour  ce  faire,  cliquez  sur  un

composant et faites-le glisser vers la position souhaitée. Vous remarquerez que le chevelu « suit » le

composant et que parfois la liaison change d'orientation car le chevelu indique toujours la liaison la

plus  courte  possible.  Un  segment  supplémentaire  (en  rouge)  apparaît  et  pointe  vers  l'ancienne

position  du  composant.  Pendant  le  positionnement  du  composant,  vous  pouvez  accéder  à  ses

propriétés en appuyant sur la touche  Tab,  le faire pivoter en appuyant sur  Espace,  effectuer un

miroir vertical ou horizontal en appuyant sur x ou y. Il n'existe malheureusement pas de règles de

placement de composants. Seules l'expérience et quelques règles de bon sens pourront vous aider. Il

faut en effet « visualiser » la future carte avec ses interconnexions et placer les composants pour

limiter la longueur des pistes de cuivre et éviter les croisements. Vous pouvez bien entendu faire

passer des pistes entre les broches des composants (sous-réserve des règles de dessin, cf. infra). 

Il  faut  commencer  par  placer  les  composants  critiques  en terme de contrainte  mécaniques  (par

exemple les connecteurs). Ensuite, il  est utile de regrouper les composants par fonction afin de

limiter les interconnexions.

Figure 8: Placement des composants et chevelu

Une fois tous les composants placés vous obtenez quelque chose de similaire à la  Figure 8. On y
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retrouve le dessin des composants (couche  Top Overlay,  pas d'impact sur la carte physique) en

jaune,  ainsi  que  leur  nom.  Les  segments  en  violet  représentent  les  bords  de  la  carte  (couche

Mechanical 1) On peut voir aussi le chevelu en segments blancs ainsi que les trous correspondants

aux broches des composants. Seuls ces derniers auront une réalité physique pour nous.

3.5 Configuration des règles de dessin

Avant de passer au routage proprement dit, il convient de définir les règles de dessin ou  Design

Rules.  Ces  règles  permettent  d'assurer  que  votre  carte  sera  physiquement  réalisables.  De  très

nombreuses options sont disponibles, vous trouverez les plus importantes pour nous en Annexe 2,

Règles DRC applicables pour une carte réalisée à Polytech. Ces règles doivent être paramétrées.

3.6 Routage

Le  routage  consiste  à   dessiner  les  interconnexions  en  cuivre  qui  relieront  les  broches  des

composants. Vous pouvez voir en Figure 9 la carte en cours de routage. Les lignes en bleu sont les

interconnexions déjà routées et vous voyez encore le chevelu représentant les liaisons non routées.

Figure 9: Routage des pistes de la carte

Pour router une nouvelle piste, cliquez sur   ou Place>Interactive Routing et cliquez bouton-

droit  sur  le  chevelu  que  vous  voulez  router. Le  curseur  se  transforme  en  croix  et  lors  des

déplacements de la souris, vous voyez apparaître une ligne sur la couche choisie. Pour modifier les

propriétés de cette ligne (couche de routage, taille de la piste, …) appuyer sur Tab sans relâcher le

bouton-droit. Par défaut le routage est interactif (il « anticipe » le meilleurs chemin, par défaut le

plus  cours  si  paramètre  non modifié  dans  les  règles  de  dessin).  Si  vous  souhaitez  changer  de
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direction ou de taille de piste (pour passer entre deux broches d'un circuit intégré par exemple),

cliquez bouton-droit ; le segment en cours se termine, mais la piste continue à être active. Lorsque

vous arrivez à la broche de destination, le curseur de la souris se trouve entouré par un cercle (cf.

Figure 9). Vous pouvez alors terminer votre routage en cliquant droit puis gauche ou Echap.

Il faut répéter cette opération pour chacun des segments du chevelu. À noter que si vous changez de

couche de routage,  un  via (trou permettant de souder une queue de résistance pour effectuer la

connexion entre les pistes situées sur deux couches différentes) est automatiquement ajouté.

Figure 10: Ajout d'un polygone de masse

Pour ajouter un polygone, cliquez sur l’icône ad hoc (cf.  Figure 10) et renseignez les différents

champs. Ceci est souvent utilisé pour réaliser des plans de masse permettant d'isoler le circuit vis-à-

vis des perturbations électromagnétiques. Dans ce cas, vous ne routerez pas les connexions à la

masse (en général appelée GND ou VSS) et vous indiquerez que le polygone doit être connecté à la

piste  GND. L'option  permet d'éviter l'apparition de zones « mortes », i.e. sans  connexion avec

d'autres zones de masse.
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Si vous ajoutez des pistes sur ce polygone, il est nécessaire de re-construire le polygone en double-

cliquant dessus.

Une fois terminée, votre carte devrait ressembler à la  Figure 11 (qui comporte en l'état quelques

erreurs …). Pour mesurer les distances, taper Ctrl + M.

Figure 11: Carte finale

Si vous avez des modifications à faire sur le PCB, c'est tout à fait possible. Afin de garder une

cohérence ente la schématique et  le PCB, il  est nécessaire,  une fois les changements ou ajouts

effectués de re-synchroniser les deux. Pour cela, Design>Update Schematic.

3.7 Vérifications

Avant de passer à l'impression des masques de la carte (ou de l'envoi vers le fabricant en cas de

réalisation industrielle), vous devez vous assurer du respect des règles de dessin. Les violations de

ces  règles  sont  normalement  représentées  par  des  points  vert  sur  les  zones  concernées  avec

l'explication de l'erreur si vous passez le curseur de souris sur la zone.

Vous pouvez aussi utiliser Tools>Design Rule Check.

A Mettre à jour.
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3.8 Export des fichiers

Une fois le placement, le routage et les vérifications effectuées, il est temps de réaliser la carte. Pour

cela, deux options sont possibles : soit la carte est réalisée à l'aide d'un procédé optique puis d'une

gravure chimique, soit par un procédé de gravure physique automatisé (machine LPKF ProtoMat

S631).

Format PDF pour impression (uniquement pour gravure chimique 
manuelle – non recommandé)

La carte peut être réalisée à Polytech'Lille par le service EEI avec un procédé de gravure chimique.

Le procédé de fabrication comporte six étapes :

− Réalisation du masque de la ou des faces (top et bottom) par impression sur un transparent.

− Transfert du motif dans de la résine photosensible déposée sur la plaque de cuivre. La résine

sert elle-même de masque pour graver le cuivre.

− Gravure  des  zones  de  cuivre  non  protégées  par  la  résine  avec  un  bain  chimique  de

perchlorure de fer.

− Perçage manuel des vias à l'aide de foret de taille adaptée.

− Éventuellement,  étamage du circuit  (protection contre  l'oxydation du cuivre et  aide à  la

soudure).

Cette section décrit comment préparer votre feuille PCB pour l'imprimer sur un transparent.

Il faut tout d'abord sélectionner la feuille PCB puis aller dans File>Page Setup. Dans Scale Mode,

choisissez Scaled Print avec une échelle de 1 et sélectionnez une impression en Mono. En cliquant

sur Advanced, sélectionnez les couches que vous voulez imprimer ; vous ferez une impression avec

la face  top, une avec la face  bottom. Pour cela, en cliquant bouton-droit, vous pouvez ajouter ou

effacer les différentes couches (cf. Figure 12) ; gardez par exemple la couche bottom (Bottom layer)

et  Mechanical 1 (contours  de  la  carte).  N'oubliez  pas  de  cocher  Hole en  cas  de  composants

traversants et éventuellement la case Mirror (en cas de routage sur la face top).

1 http://www.lpkf.com/products/rapid-pcb-prototyping/circuit-board-plotter/protomat-s63.htm
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Figure 12: Configuration de l'impression pour sortie vers fichier pdf

Vous pouvez maintenant imprimer votre dessin (File>Print) en choisissant une imprimante pdf et

en réglant la qualité d'impression à 1200 dpi et en mono.

Répétez cette opération pour la seconde face si nécessaire … Vous pouvez dès lors donner votre (ou

vos) fichiers à Thierry Flamen pour tirage de la carte !

Format Gerber (utilisation graveuse numérique - recommandé)

Cette section présente les étapes à suivre pour générer des fichiers de production au format Gerber

(standard pour la fabrication de PCB). Ces fichiers pourront alors être utilisés pour la fabrication

auprès d'un industriel ou auprès du service EEI à Polytech.

Si ce n'est pas fait, ouvrez votre fichier PCB. La génération des fichiers de production se fait en

deux étapes : la première concerne les niveaux de routage (top, bottom, mechanical layers, …), la

seconde concerne les perçages.

Allez dans Files > Fabrication Outputs > Gerber Files pour générer un fichier CAM des niveaux de

routage, vous obtenez une fenêtre de configuration (cf. Figure 13). Choisissez l'unité de travail et la

précision  souhaitée  (en général  4:3  qui  conduit  à  une  résolution  micrométrique).  Dans l'onglet

'Layer', sélectionnez les couches que vous voulez exporter. Dans l'onglet 'Apertures', assurez-vous

que  'Embedded  aperture  (RS274X)'  est  bien  cochée.  Dans  l'onglet  'Advanced',  configurez  les

options de façon similaire à la Figure 14 .

Le  logiciel  vous  génère  un  nouveau  fichier  .cam  que  vous  pouvez  sauvegarder.  Après  avoir
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sélectionné ce fichier, faites File>Export>Gerber. Vérifiez que la configuration est correcte (section

format avec les bonnes valeurs de précision) et que RS274-X est affiché. Après cela, vous pourrez

choisir les couches et le nom des fichiers de sortie (Attention au chemin de sauvegarde qui n'est pas

forcément correct pour votre projet).

Vous pouvez recommencer ces étapes pour les perçages (File>Fabrication Outputs>NC Drill File)

puis File>Export>Gerber.

Vos fichiers sont prêts pour l'envoi sur le site http://eei.polytech-lille.net/.
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Figure 14: Configuration de CAM - onglet 'Advanced'
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4. Annexe 1. Création d'une bibliothèque intégrée
Quand vous désirez utiliser un composant qui n'existe pas sous Altium Designer, il vous faut le

créer. Pour cela, nous allons voir comment faire une bibliothèque intégrée telle que celles que vous

utilisez lorsque vous insérez une résistance par exemple (library Miscellaneous Devices).

Une  librairie  intégrée  est  un  projet  particulier  dans  Altium  Designer.  Il  rassembles  divers

composants, comprenant (les trois ne sont pas obligatoirement existants) :

− une partie schématique (le dessin que l'on insère dans une feuille schematic),

− une partie empreinte (celle qui sert dans la partie PCB, avec éventuellement une vue 3D du

composant),

− un modèle de simulation Spice (avec éventuellement en plus d'autres modèles tels que ceux

utilisés pour vérifier l'intégrité des signaux, …).

Dans  cette  partie,  nous  allons  voir  uniquement  comment  créer  une  bibliothèque  intégrée

comprenant des composants avec une partie schématique et une ou plusieurs empreintes associées.

Il  faut  tout  d'abord  créer  un projet  bibliothèque par  File>New>Project>Integrated Library,  puis

sauvegarder le projet dans le répertoire adéquat afin de créer l'arborescence du projet. À ce stade, il

faut ajouter au projet un fichiers schématique par  File>New>Library>Schematic Library et un

fichier pcb par  File>New>Library>Pcb Library. Après sauvegarde des différents fichiers, vous

devriez obtenir quelque chose d'équivalent à la figure 15.
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Figure 15: Projet vierge d'une bibliothèque intégrée

4.1 Étape 1 : Création de la schématique

La première étape consiste à créer un composant schématique. Par la suite ce composant pourra être

intégré dans la partie schématique d'un projet PCB. Pour cela, cliquez sur l'onglet SCH library (ou 

s'il n'est pas présent View>Workspace Panel>SCH>SCH Library) et dans la zone Component, 

cliquez sur Add, saisissez le nom du composant puis OK, puis double-cliquez sur le nom du 

composant, vous obtiendrez quelque chose ressemblant à la Figure 16.
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Figure 16: Création du composant schématique dans une bibliothèque.

Vous pouvez dès lors renseigner les champs, notamment :

− Default designator : le nom par défaut lorsque vous placerez le composant. Ajoutez à la fin

un « ? » qui permettra au logiciel de faire la numérotation automatique des composants,

− Default  Comment et  Description :  vous  pouvez entrer  une description sommaire  et  plus

détaillée,

− Pour une utilisation simplifiée vous pouvez en rester là.

Afin de complétez cette première étape, vous pouvez dessiner le composant par  Place>Line ou

Place> Rectangle (vous pouvez bien entendu utiliser les autres formes géométriques disponibles).

Ce dessin n'a pas d'importance sur le composant, vous êtes donc libre de dessiner afin de simplifier

les connexions. En double-cliquant sur les segments dessinés vous pouvez changer la couleur, les

dimensions.  Vous  pouvez  maintenant  ajouter  les  connexions  (broches)  au  schéma,  en  utilisant

Place>Pin. Le coté « extérieur » de la broche (celui que l'on reliera à d'autres composants dans une

schématique d'un projet PCB) est noté par une croix (cf. Figure 17).
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Figure 17: Insertion d'une broche

Pour modifier les propriétés de la broche, appuyez sur la touche Tab (avant d'avoir cliqué pour

poser la broche). La fenêtre visible en Figure 18 s'ouvre.

Figure 18: Paramètres des broches

Le champ Display Name permet de renseigner l'utilisateur sur la fonction de la broche (paramètre

optionnel,  il  n'a  pas  d'influence).  Le  champ  Designator est  lui  obligatoirement  renseigné ;  par

défaut,  c'est  un chiffre  (incrémenté automatiquement  lors  de l'insertion d'une autre  broche)  qui

numérote la broche. Vous pouvez éventuellement renseigner le champ Electrical Type qui permet au

logiciel de vérifier la cohérence du circuit schématique (par exemple qu'une broche de type Input

est bien reliée à une broche de type Output). Le champ Unique Id (automatiquement rempli) est le

nom interne au logiciel pour désigner la broche (ne pas changer manuellement ce champ).

Vous répétez cette opération pour chaque broche. Vous obtenez ainsi un dessin de composant tel que

celui disponible à la Figure 19.
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Figure 19: Composant schématique final

4.2 Étape 2 : Création d'une empreinte

L'étape 2 consiste à dessiner une empreinte pour le composant. Pour cela, il faut sélectionner le

fichier PCB associé à la bibliothèque (fichier ayant l'extension  .PcbLib dans l'onglet  Project). De

même que pour la partie schématique, il faut créer une nouvelle empreinte. Trois solutions s'offrent

à vous pour cette empreinte :

– La plus simple est de récupérer une empreinte existante correspondant à celle désirée. À

partir de la datasheet du composant, vous pouvez connaître le nom de l'empreinte ou son

numéro JEDEC puis chercher si l'empreinte existe déjà sur le logiciel en allant visiter la

page  web  http://www2.altium.com/forms/libraries/designer6/PcbLib_search_ad06.asp.  Si

oui, vous ouvrez le fichier d'empreintes correspondant, vous choisissez la bonne empreinte

et vous la copiez (Ctrl + C, puis clique à l'endroit de l'origine de copie souhaitée) puis vous

la collez dans votre fichier.

– La deuxième méthode consiste à créer une empreinte vierge puis de dessiner les différents

pad en vous aidant des dimensions disponibles sur la datasheet. Vous pouvez insérer les pads

en utilisant la barre d'outil  Pcb Lib Placement (View>Toolbar>Pcb Lib Placement si non

visible). Notamment vous pouvez insérer des pad à l'aide de la deuxième icône (Figure 20).

Figure 20: Placement empreintes

– La  troisième méthode  est  d'utiliser  le  wizard  d'Altium Designer,  accessible  en  cliquant

bouton droit dans la partie Component de l'onglet PCB Library. (cf. Figure 21). Il suffit par

la  suite  de  répondre  aux  questions  posées  par  le  wizard  sur  la  taille  des  pads,  leur

espacement, etc. Vous pourrez par la suite modifier tout ce qui a été automatiquement inséré.
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– La modification des pads existants se fait

en double cliquant sur le pad (cf.  Figure

22).  Dans  la  zone  Properties,  vous

trouvez le champ Designator (le « nom »

du  pad) ;  il  est  judicieux  d'utiliser  des

numéros  correspondant  à  ceux  de  la

schématique.  Vous  avez  aussi  le  champ

Layer qui  permet  notamment  de  définir

un  pad  traversant  (avec  un  trou  pour

passer  la  patte  du composant)  allant  du

top layer au bottom layer (Multi-layer) ou

un pad sur une seule face (soit  top, soit

bottom) dans le cas de composants SMD

(Surface  Mount  Device,  ou  CMS  en

Français).  Dans  le  cas  d'un  composant

traversant,  la  zone  Hole  Information

permet de définir le trou. Enfin, les zones

Location et Size and Shape permettent de

positionner le pad ainsi que de définir ses

définitions.
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4.3 Étape 3, liaison empreinte et schématique ; création de la 
bibliothèque

La dernière étape de création du composant consiste à lier une partie schématique avec une (ou

plusieurs) empreinte. Pour ce faire, il faut sélectionner la feuille schématique puis sélectionner le

composant (disponible dans l'onglet  SCH Library) et  cliquer sur  Add Footprint.  En cliquant sur

Browse, vous ouvrez une nouvelle fenêtre résumant les empreintes disponibles dans la bibliothèque

(cf. Figure 23). En cliquant sur l'empreinte désirée, vous faire la liaison entre les broches dessinées

sur la  schématique avec les pads de l'empreinte.  Si vous avez garder des Designator cohérents

comme indiqué auparavant, la liaison se fait automatiquement. Vous pouvez le vérifier ou faire des

modifications manuelles en cliquant sur Pin Map.
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Figure 23: Ajout d'une empreinte à un composant schématique

Vous répéterez ces différentes étapes pour chacun des composants à créer (en n'oubliant pas de

récupérer les empreintes déjà existantes pour faciliter votre travail).

Pour finaliser votre bibliothèque, allez dans l'onglet Project, cliquez bouton-droit sur le nom de la

bibliothèque, puis Compile Integrated Library. Les éventuelles messages d'erreur sont à consulter

dans Messages. Si tout est correct, votre nouvelle bibliothèque est automatiquement ajoutée à la

liste des bibliothèques et vous pouvez utiliser les composants inclus !
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5. Annexe 2. Quelques conseils pour le routage …
Le routage est une étape cruciale lors de la conception d'une carte. Du routage peut résulter une

carte  fonctionnelle … ou une carte  ratée.  Il  n'existe pas de règles absolues,  et  en fonction des

applications, certains buts peuvent être recherchés ou pas.

En règle générale, il faut router les parties analogiques et les parties numériques de façon distinctes,

i.e. en rassemblant le plus possible les composants numériques dans un « coin », les composants

analogiques dans un autre. La séparation des masses (numérique et analogique) n'est pas a priori

une bonne pratique ; en revanche, il faut s'assurer que tous les plans de masses sont bien au même

potentiel. Il faut notamment  relier les masses de la couche top et celle de la couche bottom par de

nombreux  vias,  et  éviter  au  maximum les  liaisons  par  des  lignes  fines  (équivalente  en  haute

fréquence à une inductance). Les plans de masses doivent entourer la carte (pas de rupture pour

limiter les courants parasites) et ne doivent pas comprendre des zones orphelines (sans liaison avec

d'autres plan de masses).

Les liaisons intercomposants, surtout quand les signaux sont en haute fréquence, doivent être les

plus courtes possibles afin d'éviter  un effet d'antenne. En cas de signaux différentiels, pensez à

router les pistes de façon parallèle, avec une longueur équivalente.

Les condensateurs de découplage sont bien entendus obligatoires et  doivent être placés au plus

proche des broches des composants actifs.

5.1 Règles DRC applicables pour une carte réalisée à Polytech

Les principales règles de DRC sont décrites ci-après. Elles sont éditables par  Design>Rules... et

visibles en Figure 24.

Alexandre Boé 27/30



Conception circuits électroniques Mars 2015

Figure 24: Règles de DRC

Dans la partie Electrical, vous pouvez définir :

− Clearance : C'est l'espace minimal entre deux éléments de routage (pistes, vias, …). Il doit

être fixé à 10 mil.

Dans la partie Routing :

− Width : La taille minimale des pistes doit être de 12 mil, avec une préférence pour 16 mil

(attention, plus les pistes seront fines, plus le risque de micro-coupure est élevé) ; la taille

maximale peut être fixée à 254 mil … ou plus !

− Routing Via Style : Ce sont les vias ajoutés lors des changements de face de routage sur une

même piste (par exemple on commence à faire une piste sur la face top puis on finit sur la

face bottom). La taille minimale du via est de 76 mil, le trou doit être de 24 mil.

Dans la partie Plane :

− PolygoneConnectStyle :  cette  section gère ce qu'on appelle  parfois  les « thermals vias ».

Alexandre Boé 28/30



Conception circuits électroniques Mars 2015

Dans le cas d'un composant soudé sur le plan de cuivre (essentiellement la masse en ce qui

nous concerne), la soudure peut être difficile (la chaleur du fer à souder est évacuée par le

plan métallique et donc la température de la broche du composant est plus faible). Pour

simplifier la fabrication, on détoure le via du plan puis on ajoute des conducteurs. Leur taille

doit être au minimum de 16 mil.

Lors de la création des composants, n'oubliez pas :

− Taille minimale des pads : 50 mil par 100 mil pour un pad carré, 76 mil pour un pad rond.

− Taille du trou : 24 mil (le trou final sera plus grand, mais ce trou permet simplement le

centrage du foret lors du perçage).

Enfin les pistes ne doivent pas présenter d'angles à 90° ; utilisez uniquement des angles de 45 ou

135°.

5.2 Règles DRC applicables pour une carte réalisée sur la plateforme 
Télécom (IRCICA, groupe CSAM)

À venir ...
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5.3 Conversion pouce – millimètre

Le pouce est une unité de mesure anglaise (égale à 1/12 de pieds) valant 2,54 cm. Ses abréviations

les  plus  courantes  sont  in  (pour  inch)  ou  ''  (double  apostrophe).  En  électronique,  on  utilise

couramment le millième de pouce comme base de travail. Son abréviation est mil.

Par  défaut,  le  logiciel  est  configuré  pour  travailler  en  mesures  impériales.  Si  vous  décidez  de

travailler en mesure métriques, il faut penser à utiliser un pas sous-multiple de 2,54 mm car les

broches des composants sont généralement espacées de 2,54 ou 1,27 mm.

Le tableau ci-dessous donne quelques conversions entre ces différentes unités.

mm inch mil

25,4 1 1000

2,54 0,1 100

1,93 0,076 76

1,27 0,05 50

0,61 0,024 24

0,41 0,016 16

0,3 0,012 12

Alexandre Boé 30/30


	1. Introduction
	2. Flot de conception d'une carte
	3. Création du projet PCB
	3.1 Création du schéma électronique
	3.2 Simulation Spice
	3.3 Création du PCB et synchronisation avec schéma
	3.4 Placement des composants
	3.5 Configuration des règles de dessin
	3.6 Routage
	3.7 Vérifications
	3.8 Export des fichiers
	Format PDF pour impression (uniquement pour gravure chimique manuelle – non recommandé)
	Format Gerber (utilisation graveuse numérique - recommandé)


	4. Annexe 1. Création d'une bibliothèque intégrée
	4.1 Étape 1 : Création de la schématique
	4.2 Étape 2 : Création d'une empreinte
	4.3 Étape 3, liaison empreinte et schématique ; création de la bibliothèque

	5. Annexe 2. Quelques conseils pour le routage …
	5.1 Règles DRC applicables pour une carte réalisée à Polytech
	5.2 Règles DRC applicables pour une carte réalisée sur la plateforme Télécom (IRCICA, groupe CSAM)
	5.3 Conversion pouce – millimètre


